SOSOrdi.net
Identification
Pas encore inscrit(e) ? Cliquez-ici
Bandeaux anti-publicités informatifs dans une question donnée sur SOSOrdi.net pour désactiver les bloqueurs : qu'en pensez-vous ?
  • SOSMania : c'est comprehensible pour une association, bonne idée !
      33%
  • SOSPub(s) : peut-être un peu trop gros ou intrusif (j'en rêve la nuit !)
      17%
  • néoSOS : je ne les vois pas, j'ai désactivé mon bloqueur !
      0%
  • Ne sait pas / pas d'opinion
      50%
Voir les derniers sondages

Somme dans OpenOffice

Bonjour,
Je n'arrive pas à faire une simple somme de chiffres dans une colonne :
11,4 40

16,6 42
...

Premier nombre (11.4) dans la cellule F7, dernier (18) dans la cellule F60.
Idem pour les autres en G7 (40) et G60 (37).
J'utilise la formule : =somme(f7;f60) dans la cellule F62 ou G62 pour avoir le total, mais ça ne marche pas.
Mes cellules sont bien en : nombre dans "Format"
Je n'y comprends rien ...
Merci de votre aide,
Cordialement,
Carpediem81.
( en fait il y a bien deux colonnes mais le rendu ici est pas terrible, les nombres de ma colonne G se sont collés à ceux de la colonne F, mais dans ma base ils sont bien séparés )
posté le 17 Mar 2013 dans la catégorie Logiciel par carpediem81
modifié le 18 Mar 2013

14 Réponses

Bonjour,

Il doit y avoir au moins une cellule dans la plage qui n'est pas un nombre.
répondu le 17 Mar 2013 par Jacky67
modifié le 17 Mar 2013
Bonsoir Jacky67,
Non, dans les deux colonnes il n'y a que des chiffres, séparés par deux lignes.
J'ai essayé au hasard sur deux cellules éloignées, L12 et L13, avec un total en L14, avec la même méthode, et ça ne marche pas !
répondu le 17 Mar 2013 par carpediem81
C'est pourtant la seule explication plausible que je vois actuellement.
Souvent le problème se poser quand on fait un "Copier" sur un autre document, puis un "Coller" dans la feuille de calcul.

Tu peux poster ton fichier si tu veux qu'on le regarde de plus prés. ;)
répondu le 17 Mar 2013 par Jacky67
modifié le 17 Mar 2013
OK mais je fais comment ? Un copier/coller ?
Un indice : lorsque j'applique cette formule, ça me donne 0 (zéro) comme résultat. (?)
Un 2ème indice, sur une autre base de donnée, je viens de vérifier, sur plusieurs colonnes j'ai des sommes, puis sur des lignes j'ai des résultats en restes, et c'est la même formule, et là, ça marche !
répondu le 17 Mar 2013 par carpediem81
modifié le 17 Mar 2013
Tu peux héberger ton fichier chez 1fichier.com par exemple, puis tu nous donnes le lien pour qu'on le télécharge. ;)
répondu le 17 Mar 2013 par Jacky67
Aidez SOSOrdi.net !
Bonjour,
Regarde devant chaque chiffre si il n'y a pas un apostrophe

A+ François
répondu le 18 Mar 2013 par fanfan38
Bonjour,
Tu dis "dans les deux colonnes il n'y a que des chiffres, séparés par deux lignes."
il y a donc deux lignes blanches entre 2 lignes de chiffres. Les cellules de ces lignes devraient être également en format nombre, et donc afficher des "0" ( zéro ). Essaies de formater ces cellules, ou bien supprime les lignes vides.
répondu le 18 Mar 2013 par Speedycool
Bonjour,
Voilà le lien en espérant que ça marche ...
Les colonnes à additionner sont F et G.

http://qh5ef6.1fichier.com/
répondu le 18 Mar 2013 par carpediem81
modifié le 18 Mar 2013
Pour fanfan38 : bonjour, il y a une apostrophe devant !
Ça vient de là ?
Que faut-il faire ?
répondu le 18 Mar 2013 par carpediem81
 
Solution
Jacky avait raison...
il suffit d'enlever l'apostrophe et le problème sera réglé
(si il y en a beaucoup, tu le dis on fera une macro)

A+ François
répondu le 18 Mar 2013 par fanfan38
Re-bonjour, pour enlever ces apostrophes tombées du ciel ... j'ai trouvé la solution sur le net : il faut sélectionner les cellules, aller dans "Données", puis "Texte en colonne" et cliquer simplement sur OK.
Solution bizarre mais qui marche ...
En fait, qu'est-ce qui génère ces apostrophes ? ?
répondu le 18 Mar 2013 par carpediem81
Comme il est si bien dit: Texte... c'est une convertion en texte... ca arrive souvent lors d'un copié/collé...
Par contre, je connaissais pas cette solution (mais j'utilise depuis peu libre office)...
est ce que ton problème est réglé?
A+ François
répondu le 18 Mar 2013 par fanfan38
... je pense que oui dans l'immédiat, mais est-ce stable ?
De toute façon je sais maintenant comment remédier au problème, mais je ne sais pas comment ces apostrophes sont arrivées devant mes nombres !
Merci à vous,
Je mets problème résolu.
A bientôt,
Cordialement,
Carpediem81.
répondu le 18 Mar 2013 par carpediem81
Réponse automatique :

Cette question est résolue
répondu le 18 Mar 2013 par Robot SOSOrdi

Questions associées:

5 réponses 3,153 vues
posté le 7 Juil 2011 dans la catégorie Logiciel par gooliver7
6 réponses 27 vues
posté le 24 Jan 2009 dans la catégorie Logiciel par gooliver7
6 réponses 46 vues
posté le 2 Oct 2007 dans la catégorie Logiciel par olilius
3 réponses 15 vues
posté le 7 Juil 2003 dans la catégorie Multimédia par francis36
4 réponses 28 vues
posté le 15 Avr 2003 dans la catégorie Logiciel par NiTrO
Retour en haut
...