SOSOrdi.net
Identification
Pas encore inscrit(e) ? Cliquez-ici
Bandeaux anti-publicités informatifs dans une question donnée sur SOSOrdi.net pour désactiver les bloqueurs : qu'en pensez-vous ?
  • SOSMania : c'est comprehensible pour une association, bonne idée !
      33%
  • SOSPub(s) : peut-être un peu trop gros ou intrusif (j'en rêve la nuit !)
      17%
  • néoSOS : je ne les vois pas, j'ai désactivé mon bloqueur !
      0%
  • Ne sait pas / pas d'opinion
      50%
Voir les derniers sondages

erreur code php pour formulaire comptact

Bonjour :D

j’essaie de réaliser un formulaire de contacte pour mon site, en suivant un tuto https://www.youtube.com/watch?v=cnOMKUcL2_8
mais après 30 min de travail moi ça me donne un message d'erreur
http://cjoint.com/?0DoxC5527uq

donc je ne comprend pas a mon niveau j'ai regarder ci je n'avais pas mal écris, mais a moins que je sois miro, je ne trouve rien.

je vous mais en lien les captures écran des fichiers PHP que je écris.

code index.php http://cjoint.com/?0DoxHLpBKgV

code controlleurcontact.php http://cjoint.com/?0DoxIVOJ7Bk

code modelcontact.php http://cjoint.com/?0DoxKas0cS1

code viewcontact.php http://cjoint.com/?0DoxK0nQWXu

je travail avec Komodo edit 9.0 et EasyPHP-DevServer-14.1VC11

s'il vous plais, si quelqu'un veut bien m’aidè. :?
posté le 14 Avr 2015 dans la catégorie PHP par bala01

9 Réponses

Bonjour,

Il faut tester si ton élément est initialisé, cf :
http://www.commentcamarche.net/faq/1391-php-notice-undefined-index
répondu le 15 Avr 2015 par demonkill
Bonjour Demonkill :)

j'ai tenté de ré-écrire isset en choisissent le isset avec l'icon vert, j'avais sélectionné l'autre la première fois,comme sur la photo ci joint http://cjoint.com/?0Dpn62qvUEj
mais rien n'a changé.
je suis très débutant
répondu le 15 Avr 2015 par bala01
Salut,

Tu a essayé de taper toi même :
Code:
if (isset($_POST['nom'])) { $nom = htmlentities ... }
?
répondu le 15 Avr 2015 par demonkill
tu est super :D

je les écris moi même et ça fonctionne, plus d'erreur

merci beaucoup :D :D :D

je continue le formulaire grâce a toi
répondu le 15 Avr 2015 par bala01
Bonsoir,

Mais de rien ;)

Passe le pb en résolu comme cela :
http://blog.sosordi.net/2014/03/nouvel-sosordi-mais-comment-valider.html

NB : Dans ton expl tu mettait un élément "envoiMessage" qui ne correspondait pas aux éléments que tu récupérais ...
répondu le 15 Avr 2015 par demonkill
Aidez SOSOrdi.net !
désolé mais le message erreur n’apparais plus parce que j'avais écris
Code:
if (isset($_POST['nom']))
a la place de
Code:
if (isset($_POST['envoiMessage']))
mais du coût le texte "le nom et vide" lui ne s'affiche plus.
et quand j'ai remis if (isset($_POST)) les erreur son revenu
j'ai du mal :blue:
répondu le 15 Avr 2015 par bala01
Citation:
NB : Dans ton expl tu mettait un élément "envoiMessage" qui ne correspondait pas aux éléments que tu récupérais ...

je comprend mais je mais quoi, parce que dans le tuto il mais ça :?
répondu le 15 Avr 2015 par bala01
 
Solution
Houraaaaaaaaa

j'ai trouvais, c’était les majuscules, j'avais écris nom dans le viewcontact et Nom dans le modelContact

ces ton NB qui ma fais comprendre
Citation:
NB : Dans ton expl tu mettait un élément "envoiMessage" qui ne correspondait pas aux éléments que tu récupérais ...

j'ai mis du temps a comprendre :D
répondu le 15 Avr 2015 par bala01
élue le 15 Avr 2015 par bala01
Donc passe la question en résolu ... :)
répondu le 15 Avr 2015 par demonkill

Questions associées:

9 réponses 54 vues
10 réponses 65 vues
posté le 26 Jan 2005 dans la catégorie PHP par Alexa
4 réponses 101 vues
posté le 29 Juin 2015 dans la catégorie PHP par Stéphanie999
2 réponses 13 vues
posté le 1 Fév 2008 dans la catégorie PHP par sly95200
6 réponses 37 vues
posté le 10 Avr 2006 dans la catégorie PHP par Bimini
Retour en haut
...